Taegis Foxtrot Detection Delays

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 09:06 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2025 - 20:49 EDT

Identified

Users in the Taegis Foxtrot environment may be experiencing continued delays for all detections. Team is working to reduce this delay.
Posted Oct 28, 2025 - 20:16 EDT