All environments: newly created cases (investigations) are not appearing, even though they do exist

Incident Report for Taegis XDR

Resolved

The engineering team deployed an update to the UI that makes it clearer how the default date filter functions. (No code/logic change was necessary.)
Posted Oct 08, 2025 - 13:23 EDT

Identified

Our engineering team has identified a bug in the Taegis user interface. They are working on a bug fix.
Posted Oct 08, 2025 - 10:32 EDT

Update

Engineering is continuing to investigate the root cause of this issue. As an alternative workaround, users may wish to go to User Profile & Settings -> Time Zone and set their profile time zone to UTC.
Posted Oct 08, 2025 - 09:14 EDT

Investigating

Users are reporting that newly created cases (investigations) are not appearing, even thought they have been created.

Engineering is investigating.

As a workaround, users can expand Created, In Range search--suggest 1 day before and after--and the case should appear.
Posted Oct 07, 2025 - 22:25 EDT