Support is investigating an issue where some users' browsers are crashing when accessing the Alerts tab.

Incident Report for Taegis XDR

Resolved

A fix has been deployed to all environments. The Alerts tab is functioning normally.
Posted Mar 06, 2025 - 18:13 EST

Monitoring

A fix has been deployed and confirmed.
Posted Mar 06, 2025 - 18:11 EST

Update

Support has identified a workaround: users can reload the Alerts tab in their browser to rectify the issue. (This workaround does not require that users reset their preferences.)

Support is continuing to work on fixing the root cause.
Posted Mar 06, 2025 - 17:22 EST

Update

We are continuing to investigate this issue.
Posted Mar 06, 2025 - 16:44 EST

Investigating

Issue is being investigated.

A workaround has been identified: users may choose to click Reset Preferences in User Profile & Settings.

WARNING: this work around will reset user preferences. Depending upon how this affects user workflow, they may choose to wait for a fix.
Posted Mar 06, 2025 - 16:44 EST