Our backlog has caught up, and we can mark this incident resolved. There was no data loss, however some changes to endpoint tagging/metadata may not appear in the UI due to a cache expiry. In this case, please retry adding tags again.
Posted May 15, 2025 - 14:05 EDT
Update
We are continuing to watch the backlog go down, still monitoring progress.
Posted May 14, 2025 - 19:07 EDT
Update
We are still watching the backlog go down while continuing to monitor progress.
Posted May 14, 2025 - 16:41 EDT
Monitoring
Our service has been restored and is working correctly, and we are currently working through a backlog to catch up. Asset searches should become more functional as we continue to monitor the progress.
Posted May 14, 2025 - 11:56 EDT
Update
We are continuing to work on a fix for this issue. Asset search is still being affected, and the team is actively working on a fix.
Posted May 14, 2025 - 09:13 EDT
Identified
Taegis XDR users in the Delta environment maybe experiencing slower search performance. We're currently working on improving search return times.