All environments: unable to attach alerts to cases (investigations)

Incident Report for Taegis XDR

Resolved

Issue is fixed.
Posted Apr 23, 2026 - 13:50 EDT

Monitoring

A fix has been deployed. We are monitoring to verify that all function is restored.
Posted Apr 23, 2026 - 13:10 EDT

Identified

Currently users are unable attach alerts to cases (investigations). Our engineers have identified the cause and are working on deploying a fix. Alerting is still functioning, and there is no data loss risk.
Posted Apr 23, 2026 - 12:49 EDT