Security Operations team is delayed in triaging Taegis alerts
Incident Report for Taegis XDR
Resolved
Service is restored, and the Security Operations team is catching up on the backlog.
Posted 3 months ago. Oct 03, 2024 - 17:55 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Oct 03, 2024 - 17:01 EDT
Investigating
Due to an outage, our Security Operations team is delayed in triaging Taegis alerts. We are actively troubleshooting.
Posted 3 months ago. Oct 03, 2024 - 15:26 EDT