Current AWS Outage Impeding SOC response times

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:20 EDT

Update

We're also seeing delays in Red Cloak endpoint telemetry ingestion due to current AWS outage. Team will continue to monitor the situation.
Posted Oct 20, 2025 - 14:22 EDT

Monitoring

Taegis SecOps working through a high backlog due to the AWS outage that's happening today. Expect delays with ZenDesk responses and other interactions with SOC.
Posted Oct 20, 2025 - 13:25 EDT