Taegis Detection Delay in all Environments

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 01:36 EST

Update

We are still experiencing delays in the Taegis Foxtrot environment. All other environments have recovered. We'll continue to monitor the situation.
Posted Dec 10, 2025 - 21:10 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2025 - 19:38 EST

Identified

All Taegis environments are currently experiencing a detection delay. Team has identified the issue and is implementing a fix.
Posted Dec 10, 2025 - 18:13 EST