Delay in Alert, Detections triage in Echo.

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted May 03, 2026 - 11:21 EDT

Investigating

We are actively looking into the delay in Alert / Detections triage in Echo.
Posted May 03, 2026 - 08:37 EDT