US-2/Delta - Delay in attaching alerts to investigations

Incident Report for Taegis XDR

Resolved

The issue has been resolved.
Posted Jul 25, 2024 - 12:20 EDT

Investigating

We are currently investigating an issue with a delay in attaching alerts to investigations. Alerts are still being generated normally.
Posted Jul 25, 2024 - 11:52 EDT