Taegis environments Delta and Foxtrot are currently experiencing ingest lag

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 18:12 EDT

Update

Lag has recovered in the Delta environment. We are still working through backlog in Foxtrot.
Posted Jul 30, 2026 - 14:31 EDT

Monitoring

We are seeing about an hour delay in alerts in Delta and Foxtrot, but improving. Will continue to monitor.
Posted Jul 30, 2026 - 11:41 EDT

Identified

Delta and Foxtrot environments are current experiencing telemetry ingest lag. Users may see delayed detections during this time.
Posted Jul 30, 2026 - 10:52 EDT