Search Performance Latency in all Taegis Enironments

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 17:50 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2025 - 16:59 EDT

Identified

Users in all environments may be experience degraded search performance at this time. Fixes are being implemented currently.
Posted Sep 02, 2025 - 16:52 EDT