Crowdstrike Falcon update error - worldwide

Incident Report for Taegis XDR

Resolved

CrowdStrike has deployed a fix
Posted Jul 19, 2024 - 09:06 EDT

Update

Crowdstrike has identified the issue and is rolling out a fix.
Posted Jul 19, 2024 - 09:05 EDT

Monitoring

A recent update to Crowdstrike Falcon on Windows is causing widespread infrastructure issues. Both Crowdstrike and Microsoft are working on a fix.
Posted Jul 19, 2024 - 04:27 EDT