ITDR is down in all regions

Incident Report for Taegis XDR

Resolved

Service restoration confirmed. ITDR is operational.
Posted Nov 20, 2025 - 16:23 EST

Monitoring

Engineering identified a breaking change that was rolled back. Service is restored.
Posted Nov 20, 2025 - 16:00 EST

Investigating

ITDR is down in all regions. Engineering is actively investigating.
Posted Nov 20, 2025 - 15:55 EST