US-1/Charlie - Registry Event Delays

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Jun 13, 2024 - 23:57 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 13, 2024 - 20:53 EDT

Investigating

We have an investigating an issue causing registry events to be delayed. We are working on a fix. There is no data loss.
Posted Jun 13, 2024 - 19:24 EDT