Event processing delays in Taegis Echo environment

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 19:11 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2025 - 18:37 EDT

Identified

Users in the Taegis Echo environment may be experiencing delays in events processing. We have identified the problem and are working on a fix.
Posted Sep 25, 2025 - 16:42 EDT