Delta: Stolen Credentials Detector Delay

Incident Report for Taegis XDR

Resolved

All systems are operating as normal.
Posted Jun 26, 2025 - 14:10 EDT

Monitoring

Our systems are operating as normal, however we are continuing to work through a data backlog for alerting. The average delay is just under 30 minutes.
Posted Jun 26, 2025 - 13:53 EDT

Update

Our systems are operating as normal, however we are continuing to work through a data backlog. The average delay is just under five hours.
Posted Jun 26, 2025 - 12:19 EDT

Update

Our systems are operating as normal, however we are continuing to work through a data backlog. The average delay is now around five hours.
Posted Jun 26, 2025 - 10:45 EDT

Identified

We are seeing a delay in Delta for Unseen IP/ASN/Country/User Agent alerts, which may result in a delay of the Stolen Credentials detector. Our engineers have identified the problem and are working to implement a fix.

The current maximum delay is six hours.
Posted Jun 26, 2025 - 09:21 EDT