Advanced Search Errors In Echo Environment

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 12:21 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 16, 2025 - 11:26 EDT

Investigating

We're aware of a search functionality issue affecting some users in our echo environment. Our team is actively investigating the issue. We appreciate your patience as we work toward a resolution.
Posted Jun 16, 2025 - 11:11 EDT