Auth processing delays in Charlie, Delta & Echo

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 08:36 EDT

Update

Echo is back to normal, auth alerts from Charlie and Delta are still delayed but recovering...
Posted Aug 21, 2025 - 14:15 EDT

Update

We are continuing to monitor for any further issues.
Posted Aug 21, 2025 - 11:34 EDT

Monitoring

Charlie Delta and Echo are currently experiencing auth alert processing delays and are recovering
Posted Aug 21, 2025 - 11:32 EDT