cloudflare outage

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 04:15 EST

Monitoring

There is currently an incident with Cloudflare - you may have difficulty reaching support until it is resolved.
Posted Dec 05, 2025 - 04:06 EST