echo: Elevated Latency affecting alerting

Incident Report for Taegis XDR

Resolved

The data backlog in echo is cleared. All systems are functioning as normal.
Posted Jun 25, 2025 - 18:01 EDT

Monitoring

The underlying issue has been addressed. Some alerts will be delayed in echo as we are continue to work through our backlog. We anticipate that the backlog will be cleared by 8:00 pm EDT.
Posted Jun 25, 2025 - 16:45 EDT

Update

The increased latency is from an internal service; it is causing an delay in most alerting.
Posted Jun 25, 2025 - 15:17 EDT

Identified

We are seeing elevated latency across all APIs in the echo environment. Our engineers have identified the issue and are working to resolve it.
Posted Jun 25, 2025 - 15:00 EDT