ITDR unresponsive on UI

Incident Report for Taegis XDR

Resolved

Incident has been resolved and service has been restored
Posted Jan 13, 2026 - 13:22 EST

Monitoring

A rollback was made and service should be returning shortly
Posted Jan 13, 2026 - 13:12 EST

Investigating

We are aware of an issue affecting our authentication between platforms that is affecting ITDR and XDR EAP customers
Posted Jan 13, 2026 - 13:03 EST