Taegis Application Disuptions

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 08:00 EDT

Monitoring

AWS is currently experiencing an outage in the US-EAST-1 region. Teagis users may be seeing login errors or degraded performance at this time. We will be monitoring the situation reported at https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 04:29 EDT