Alerts are delayed by up to three hours

Incident Report for Taegis XDR

Resolved

Alerting is caught up.
Posted Aug 16, 2025 - 03:57 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 16, 2025 - 03:00 EDT

Investigating

Alerts are delayed by up to three hours in charlie and delta. Other environments are delayed by up to one hour. We are working to clear the backlog.
Posted Aug 16, 2025 - 03:00 EDT