Delay in Alert Processing for Subset of Alerts in Charlie

Incident Report for Taegis XDR

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 20:06 EDT

Investigating

There is a delay in processing a subset of Alerts in Charlie and we are actively working on it
Posted Apr 24, 2026 - 16:58 EDT